Skip to the end of navigation

Welcome to the Community!

4K Ultra HD TV

Showing results for 
Search instead for 
Do you mean 
Reply
Enthusiast
Posts: 7
Registered: ‎01-16-2017
Message 31 of 56 (3,399 Views)

Re: Seem to have multiple problems after Dec 2016 software update - xbr55x850c

I have mine connected to my wireless network but before this update my set worked great. Also according to Sony's tech support there is an update coming out in about a week that will be fixing all our issues.

Highlighted
Rookie
Posts: 1
Registered: ‎03-13-2017
Message 32 of 56 (3,072 Views)

Re: Seem to have multiple problems after Dec 2016 software update - xbr55x850c

I went online and chatted with someone from Sony tonight.  I have had all the same issues to include not being able to turn the tv on without unplugging it.  

 

They said that the marshmallow update is coming out tonight.  

 

He was sure that this would fix the issues.  The engineers have been working on it for a long time according to him.  I am never the person who tries it the night the update comes out but hopefully this will work. 

Enthusiast
Posts: 1
Registered: ‎01-09-2016
Message 33 of 56 (3,006 Views)

Re: Seem to have multiple problems after Dec 2016 software update - xbr55x850c

These are exactly the problems I am having now. I contacted Sony and got this response:

We are really sorry for the trouble and inconvenience.

We appreciate your efforts in performing the trouble shooting steps.

Since the issue persist after troubleshooting steps, the device need to be diagnosed by a technician. Let me help you with the link to request service:

https://esupport.sony.com/US/p/service.pl

Should you have further questions, please feel free to get back to us or contact our Phone support team (1-800-222-7669, Mon - Fri from 8am - 12am ET (Midnight) & Sat - Sun & Holidays from 10am - 9pm ET) and will be glad to assist you further.

Thank you for choosing Sony and have a good day ahead.

Regards,

Alan

(C9GM)

Sony Video and Sound Email Response Team.

 

I have contacted that number and they just tell me my TV has a hardware problem. Frustration is what I am feeling since I had zero problems before this update.

 

Enthusiast
Posts: 7
Registered: ‎01-16-2017
Message 34 of 56 (3,001 Views)

Re: Seem to have multiple problems after Dec 2016 software update - xbr55x850c

Gwirtel I feel your pain as I was told all the above. I was told that my TV had hardware issues after all of the resets and hoops they had me jump through and that an engineer would contact me in a couple of days only to have a tech support person call me back and change that the issues was software now and not hardware. And that there would be a software update out in a couple of weeks well its been 3 weeks now and still no update.  I see from the post before yours that it would come out last night still no update I've ck 2 times so far today. At this time I think tech support just tells you there is a fix around the corner to get you off of the phone. I know i'm tired of waiting to get this taken care of and I haven't been able to watch Amazon Prime, Netflix or Hulu for almost 3 months now, that is why I got a smart TV in the first place. Sony PLEASE get this taken care of.

Enthusiast
Posts: 7
Registered: ‎01-16-2017
Message 35 of 56 (2,751 Views)

Re: Seem to have multiple problems after Dec 2016 software update - xbr55x850c

Back on 2-21-17 that was my third post on this issue, I was told that there would be an update for the problems with Android 6.0 out in a couple of weeks well its been 5 weeks now and still no update and on 3-13-17 B28lamb was told the update was coming out that night, checked this morning and still no update. So I decided to contact Sony Tech Support again today. So now they are going to send out a repairman and replace the circuit board that has the updated 6.0 marshmallow operating system on it with a new circuit board that has the previous operating system that worked on it. I don't know why it has to be so difficult to get the original operating system back, but at this point I don't care as long as it works like it did when when I first got the TV set. I will update this post after the circuit board is installed and let you know if it fixed the TV. I will be turning off the auto update function if this fixes all my problems.

Rookie
Posts: 2
Registered: ‎03-24-2017
Message 36 of 56 (2,658 Views)

Re: Seem to have multiple problems after Dec 2016 software update - xbr55x850c

Same problems y'all are having. It's bad they haven't fixed this yet. Sony used to mean quality. In the age of social media, do they really want hundreds of customers posting horror stories??
Rookie
Posts: 2
Registered: ‎03-24-2017
Message 37 of 56 (2,630 Views)

Re: Seem to have multiple problems after Dec 2016 software update - xbr55x850c

Updating....

 

So I called Sony Support, and they answered after a while. It was pretty ****** impressive that I could go into my tv settings and generate a number and read it to him --which allowed them to take control of my tv menu and look at things. (You expect remote access on computers these days, so it's nice to see on a tv as well.)

 

Here's what he did:

Navigating to our apps, he cleared the data/cache on Netflix and Amazon video apps, then restarted the tv.

 

We watched Netflix the rest of the evening without any of the Sony firmware error messages popping up. That it MAY BE the APPS causing the trouble sort of makes sense. In the past when the firmware error messages locked our tv, restarting the tv usually solved the problem. From time to time, we also plugged in our ROKU and accessed Netflix or Amazon using ROKU instead of the downloaded Sony netflix/amazon apps, ...and that seemed to keep the tv's firmware from ****** out.

 

Here's  hoping.

Apprentice
Posts: 10
Registered: ‎03-25-2017
Message 38 of 56 (2,584 Views)

Re: Seem to have multiple problems after Dec 2016 software update - xbr55x850c

Hi!  Is your TV still working OK?  I have had the same problems you described since the December 2016 upgrades.  Sony tech support was worthless.  I cleared the cache on my Amazon app but it still won't work.

Enthusiast
Posts: 2
Registered: ‎04-22-2017
Message 39 of 56 (1,856 Views)

Re: Seem to have multiple problems after Dec 2016 software update - xbr55x850c

After months of frustration my TV is finally fixed. Here is what finally remedied the issues on my XBR55X850C:

 

Tried every possible remedy prescribed on the Sony web board with no success. Finally went to BB to talk to a Geek Squad rep and like all the previous ‘Sony speak’ was informed Sony knows of the problems with the update and to be patient for the ‘new update that was coming that would alleviate all issues’.

 

Waited another 4 weeks with no update so went to BB again. This time in as much as I purchased an extended warranty with my television and the promise of a new update was not coming to fruition, I demanded having my 1 year old television either fixed within the next 10 days or replaced with a new one if it could not be repaired by them. I was promptly giving an 800 number to call and after a lengthy conversation with a Geek Squad tech explaining not only my frustration but also the symptoms I was experiencing that they were ordering a new main board for my set and that 2 technicians would come to my home to install the new man board.

 

About a week later I received the new main board as I was promised and two days later a call from Geek Squad confirming a date when the service call would be performed. The 2 Geek Squad technicians arrived on time, removed the old board and replaced the new on in minutes and re-mounted my television to my mount. I was then informed that they then had to ‘flash’ the board with the firmware. I assumed it would be with either the original firmware or at the least the firmware just prior to the December Version 6.01 Marshmallow that had given me all the performance issues. Much to my disappointment and chagrin, I was informed that ‘no’, they (Geek Squad) had to flash with again the newest firmware, Version 6.01 Marshmallow.

I went along with the install of the new board and the flash again of the same troublesome firmware and watched as the tech started my TV after completion. He explained to me that the problem was not necessarily the version of the software as much as the possibility that the update I got in December was a corrupted download and installation, much like a bad download and update of a MS Windows update that we get periodically. I was skeptical, but thanked him for his service and told him that if my problem was not resolved that I would call again at the first sign of the problems I was previously experiencing.

 

Whether or not it was indeed the fault of a corrupted download or the main board was the culprit, it has now been 2 weeks since the service call and my television has been working wonderfully!!! I cannot thank the folks at Geek Squad enough and believe now as the tech explained to me that the problem was indeed the fault of a corrupted download of the update. I once again am enjoying my Sony TV and hope some of you get relief through whatever channels either it be, Sony or Geek Squad, as I did.

Apprentice
Posts: 10
Registered: ‎03-25-2017
Message 40 of 56 (1,879 Views)

Re: Seem to have multiple problems after Dec 2016 software update - xbr55x850c

Prime has been choppy with video since December. A software update from Sony in the past week seemed to help Prime but now I have new issues. Netflix won't work and the TV needs to reboot every time I want to access my Direct TV. I think Sony should give up on Google as the operating system for apps or offer to buy back the TV sets they can't seem to get to work right.

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook