Skip to the end of navigation

Welcome to the Community!

Alpha NEX Cameras

Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Apprentice
Posts: 10
Registered: ‎01-24-2017
Message 1 of 3 (164 Views)

5R with 18 55 kit lens aperture problem

My 5R randomly showed   f.-- in different modes. There is no way to control the aperture value of the 18 55 kit lens. Occasionally, the focus points are not shown normally. It apppeared to be a huge green rectangle surrounding the whole LCD screen. Camera not set to zoom. Focusing is working fine.

 

I have searched several forums and was given to understand that there are various causes to this problem.

 

a. contact problem (cleaning is required)

b. broken aperture mechanism (send camera to Sony for repair)

c. broken flex cable as part of b above (same as above)

d. loose mount ring of the camera causing a above (contact problem)

e. unidentified problem and can't fix by user(send to Sony for repair)

 

I have finally find a way to fix it. (not sure if it is a permament fix. at least it doesn't show the problem any more after my little diy repair) 

 

Before I share my diy repair, I want to invite your idea and experience.

 

Thank you.

Moderator
Posts: 511
Registered: ‎10-21-2014
Message 2 of 3 (102 Views)

Re: 5R with 18 55 kit lens aperture problem

Hi Ezpop,

 

You can try shooting in Aperture Priority Mode.

 

1. Set the shooting mode to [Aperture Priority].

2. Select the desired value with the control dial.  

    Smaller F-value: The subject is in focus, but things in front of and beyond the subject are blurred.

    Larger F-value: The subject and its foreground and background are all in focus.

3. Adjust the focus and shoot the subject.

 

If my post answers your question, please click the "Accept as Solution" button.

 

Regards,

-Anthony

Apprentice
Posts: 10
Registered: ‎01-24-2017
Message 3 of 3 (97 Views)

Re: 5R with 18 55 kit lens aperture problem

Thank you for your response.

 

It has nothing to do with the setting. The reading of F.-- indicates that there is a problem of contact between the lens and the camera.

 

I found a way to solve the problem but may be it's just my camera/lens.

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook