Skip to the end of navigation

Welcome to the Community!

Alpha NEX Cameras

Showing results for 
Search instead for 
Do you mean 
Reply
Enthusiast
Posts: 2
Registered: ‎02-11-2017
Message 1 of 4 (197 Views)

a6000 lens error

I just purchased an a6000 with an 18-55mm lens (model SEL1855) and a 55-210mm lens (model SEL55210). When using the 18-55mm lens, after taking a few shots, I get an error message: "Check that a lens is mounted. For an unsupported lens, set "Release w/o Lens" in the menu to "Enable"." 

 

The problem goes away when I reset the camera only to reappear after a few minutes. I've cleaned the contacts gently with a pencil eraser and there's no sign of any damage. Any help is much appreciated. 

Professional
Posts: 1,581
Registered: ‎01-08-2015
Message 2 of 4 (181 Views)

Re: a6000 lens error

Sony stopped selling the A6000 with the 18-55 lens years ago. Where did you buy it from?

¹ The Lens is the Thing
² 'Full Frame' is the new 'Medium Format'
³ "One good test is worth a thousand expert opinions." - Tex Johnston, Boeing 707 test pilot.
Enthusiast
Posts: 2
Registered: ‎02-11-2017
Message 3 of 4 (176 Views)

Re: a6000 lens error

I bought it 'open box' from B&H.
Professional
Posts: 1,581
Registered: ‎01-08-2015
Message 4 of 4 (163 Views)

Re: a6000 lens error

Try leaving the battery out for a full 24 hours. When you put the battery back in and trun the camera on, it should prompt you for the date and time.

¹ The Lens is the Thing
² 'Full Frame' is the new 'Medium Format'
³ "One good test is worth a thousand expert opinions." - Tex Johnston, Boeing 707 test pilot.

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook