Skip to the end of navigation

Welcome to the Community!

Blu-Ray - Netflix, Online Video, Network & Internet

Showing results for 
Search instead for 
Do you mean 
Reply
Enthusiast
Posts: 5
Registered: ‎11-12-2012
Message 1 of 5 (3,635 Views)
Accepted Solution

My Sony BDP-BX650

My new Sony BDP-BX650 has trouble streaming video from Netflix. Sometimes it streams very well and other times it stops and starts every few seconds. Also, the unit freezes up about once per week. When that happens I have to diconnect/reconnect the power cord to get it going again. We did not have these issues with our old Sony BDP-S185.

 

I have set the DNS to 8.8.8.8 and 8.8.4.4. This only helped streaming a little. The new player doesn't seem to buffer content at all. Our old player did. 

Enthusiast
Posts: 5
Registered: ‎11-12-2012
Message 2 of 5 (3,604 Views)

Re: My Sony BDP-BX650

Oddly enough, disabling the Quick Startup feature seems to have cured my streaming issue. I suspect there is a problem with the Netflix app that only shows after the app has been running for a while. Cold booting clears the issue for a period of hours. Hopefully, this will help someone else.

Rookie
Posts: 1
Registered: ‎01-22-2017
Message 3 of 5 (1,617 Views)

Re: My Sony BDP-BX650

Unfortunately the cure for your issues, which are the same issues that I have for the same unit, has not worked for me. How sad, since I was really hopeful. thank you anyway.

Enthusiast
Posts: 5
Registered: ‎11-12-2012
Message 4 of 5 (1,043 Views)

Re: My Sony BDP-BX650

Here I am a year later and my streaming problem is back and worse than ever. Now it affects all apps, not just Netflix. I haven't changed anything on the BDP-BX650. I can stream just fine with any other system. Only the BX650 has this issue. When first powered up it will stream just fine for a few hours, then it will start freezing intermittently. The only cure is to power it off and back on. If I don't do that quickly enough the BX650 will lock up tight and won't respond to the remote or the controls on the unit itself. I have to disconnect it from power for a few seconds, then it will work again after reconnecting power. This is either a firmware or hardware issue. I have a solid 240 Mbps down 12 Mbps up internet connection (xfinity). I tried to run an Internet speed test from the browser on the BX650, but as soon as it hit 122 Mbps I got an out of memory error.

 

BTW, anyone experiencing fluctuating Internet speeds above 100 Mbps are most likely having router issues. Most consumer routers can't handle speeds above 150 Mbps reliably. I'm using the Ubiquiti EdgeRouter X. The best $50 I've spent.

 

Enthusiast
Posts: 5
Registered: ‎11-12-2012
Message 5 of 5 (1,042 Views)

Re: My Sony BDP-BX650

I re-ran the speed test and it hit 240 Mbps before it ran out of memory. 33 ms latency. On my desktop computer the latency is only 22 ms for the same test.

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook