Skip to the end of navigation

Welcome to the Community!

Blu-Ray - Netflix, Online Video, Network & Internet

Showing results for 
Search instead for 
Do you mean 
Posts: 1
Registered: ‎02-18-2017
Message 1 of 3 (2,804 Views)

S3500 - Software Wont Update



My S3500 bluray player will not update to the latest firmware.  When I switch it on I get a message advising me of new software that is avaialable and it prompts me to download and update it.  When I try to do this it goes to the progress screen (with 0% listed), and after a few minutes it after not moving from 0% it advises me that there is an error, and to try again.


My internet conection is fine when I test it.


I then downloaded the latest firmware onto a USB thumb drive, unzipped the file as per the instrcutions on the Sony website, and tried to update the firmware via USB.  When I try to do this I get a message advising me that new firmware has been detected and whether I want to update. I proceed with the update - my S3500 switches off and does not turn back on.  When I switch it back on (after the 1st time waiting a few minutes for it to turn on by itself, which it didnt), it automatically goes to the update screen with the status bar (again at 0%), and I then get the same error message.


I have exhausted all options. Ive tried to update from the Setting options screen also, with no luck.


Please assist as I now can not watch Netflix because it tells me to update my software.



Posts: 399
Registered: ‎02-02-2017
Message 2 of 3 (2,747 Views)

Re: S3500 - Software Wont Update

Hi RogerRoger33,


Welcome and thank you for considering the SONY Community!

For further assistance regarding your concern, please contact the Sony offices/Sony representative offices nearest to your place of residence in Asia Pacific region Due to proximity, they are in a better position to respond to your questions or concerns.




Posts: 6
Registered: ‎11-12-2012
Message 3 of 3 (2,579 Views)

Re: S3500 - Software Wont Update

RogerRoger, I am/was having the same issue, while I still can't update the firmware, if you go into Setup > System Settings > Software Update Notification = On, turn this to off and you should be able to use it again.

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook