Skip to the end of navigation

Welcome to the Community!

Cybershot Cameras

Showing results for 
Search instead for 
Do you mean 
Reply
Enthusiast
Posts: 3
Registered: ‎06-16-2017
Message 1 of 2 (247 Views)

RX100-1 Zoom, Menu-, Fn-, Center-, Play-, ?- Button not working! But MOVIE Button works

I am stuck in Quebec City / Canada with a Sony RX100-1 which still can take pictures, but with some obstacles:
Suddenly the zoom did not work anymore. Neither the W/T nor changing zoom by hand will work. Additionally following buttons do not react anymore:
MENU, Fn, Play, ? and the Center Button. When changing the mode selector on top there is also no feedback. But when changing and taking a photo afterwards, it will show the help screen for the new mode and even the OK button will work to dismiss this screen. So far I read some instrcutions here, the following did not work here yet:
taking out the battery, press and hold power for 30 seconds up to 1 minute, turning battery in. nothing changes.

The only way I can come back to selecting MENU is this: connecting by USB cable to computer, disconnect, then I can select MENU exactly once. Did then a factory reset there. Did also not work out.

How can I fix this? It is a big pity that the camera suddenly stopped to work near the middle of my journey through Canada. Is there a repair service in Quebec city? I also tried to re-install the firmware v1.10, but the updater blocks and aborts this, because it is already installed. Are there other tricks to do some kind of hardware reset? For me it looks like maybe just a software problem, as the buttons (except zoom, never works anymore) seem to work when camera was connected to USB before..

Quick response would be veeery nice Smiley Happy

Highlighted
Enthusiast
Posts: 3
Registered: ‎06-16-2017
Message 2 of 2 (200 Views)

Re: RX100-1 Zoom, Menu-, Fn-, Center-, Play-, ?- Button not working! But MOVIE Button works

Dont know why exactly, but when using camera next day with the fixed zooms and not working buttons.. shoot some photos.. after a while zoom and buttons worked again. Could be a bug with the panorama function, first I hardly could leave this due to non working buttons, but I think after I finally left it to another method, zoom worked again. Is this a software failure or was it just luck and it is a temporary hardware failure?

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook