Skip to the end of navigation

Welcome to the Community!

Cybershot Cameras

Showing results for 
Search instead for 
Do you mean 
Reply
Rookie
Posts: 1
Registered: ‎11-09-2015
Message 1 of 8 (3,078 Views)

Sony RX100 Mk III buttons not working

I have a RX100 Mk III with about 800 frames shot on it. It takes great pics. However, out on a little vacation this last few days and the menu button stopped working, leaving me with no way to fully control what I was capturing. There is no way to get to the reset menu without the menu button. How do I get this resolved?

Moderator
Posts: 1,165
Registered: ‎07-16-2015
Message 2 of 8 (3,052 Views)

Re: Sony RX100 Mk III buttons not working

Hi ethernectar,

 

Welcome to the Sony Community!

Sorry to know that you are experiencing this issue with your camera. If the buttons does not respond, one way to resolve it is by doing a power reset. You just turn OFF camera and remove the battery. Press and hold the ON button to drain any initial charge in the camera. After a minute you can now release the Power button. Reinsert the battery. Turn it back ON and test if the unit will work now. If the buttons still does not respond, the unit may need to be checked at our service facility. Please set up repair request here.

 

If my post answers your question, please mark it as "Accept as Solution".
Best regards,
Zander

Rookie
Posts: 1
Registered: ‎03-20-2016
Message 3 of 8 (2,896 Views)

Re: Sony RX100 Mk III buttons not working

I'm curious about whether zandere's answer worked for anyone with this issue. I've had my RX100 mark iii for about four days and today the menu and delete buttons have stopped working, so has the zoom out function, and the control wheel only scrolls in one direction and none of the buttons on the control wheel seem to work.

I've tried zandere's trick to no avail. This is very disappointing for an expensive piece of equipment that is more or less brand new.
Enthusiast
Posts: 4
Registered: ‎12-19-2014
Message 4 of 8 (2,854 Views)

Re: Sony RX100 Mk III buttons not working

[ Edited ]

Zander's power reset worked for me after all the buttons stopped responding.  Took out the battery and pressed the on button for about 30 seconds to discharge.  Just taking out the battery without pressing the on button did not work.  My Sony is first gen RX-100 and have had for many years with no problem so was surprised when the buttons froze without warning.  but the reset fixed it.  Just remember to press the power button to discharge after taking out the battery or it will not work.

Rookie
Posts: 1
Registered: ‎12-17-2016
Message 5 of 8 (2,240 Views)

Re: Sony RX100 Mk III buttons not working

I have the same problem. Had the camera for a year and worked well. Now I cannot take photos, buttons work only in video mode and when I switch to ony other mode buttons stop working. Tried reseting, formated card, reset setting, updated firmware to 1.20 to no avail. Any suggestions???

Expert
Posts: 631
Registered: ‎10-21-2014
Message 6 of 8 (2,201 Views)

Re: Sony RX100 Mk III buttons not working

Hi Datel,

 

Thank you for considering Sony Community!

 

Please try to perform a manual reset on the camera:

 

  1. Remove the battery from the camera.
  2. Set the power switch to ON.
  3. Press and hold the shutter button for 2 minutes.
  4. Set the power switch to OFF.
  5. Insert the battery back to the camera.
  6. Set the power switch to ON to see if the camera will turn on.

 

For further assistance, please contact the Sony offices/Sony representative offices nearest to your place of residence in Asia Pacific region at http://www.sony-asia.com/locale-selector?hpid=countryselector:AsiaPacific. Due to proximity, they are in a better position to respond to your questions or concerns.

If my post answers your question, please click the "Accept as Solution" button.

 

Regards,

-Anthony

 

Enthusiast
Posts: 3
Registered: ‎06-16-2017
Message 7 of 8 (1,347 Views)

Re: Sony RX100 Mk III buttons not working

I can add this did not work for me (the first explanation to remove battery, wait 30s..1m by holding power etc), but I own a RX100-1. In my case zoom does not work at all anymore (neither by W/T nor manually) and additionally to the MENU button most other buttons also do not work anymore, except the MOVIE button (which I nearly never use). I described further details here: https://community.sony.com/t5/Cybershot-Cameras/RX100-1-Zoom-Menu-Fn-Center-Play-Button-not-working-...

Is there really no way to force some kind of hard reset, e.g. by holding some specific buttons (uh!) together when turning on etc?

Highlighted
Rookie
Posts: 1
Registered: ‎07-06-2017
Message 8 of 8 (1,133 Views)

Re: Sony RX100 Mk III buttons not working

Hello Anthony, 

 

I have been using Sony RX100 ii for 6 months. But unfortunately my camera button is not working last few days. Suddenly all the button is taking wrong commands. e.g if i want to press the movie button it shows me menu.

 

What should I do now. It would be great if you could help me ASAP.  

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook