Skip to the end of navigation

Welcome to the Community!

F5 & F55

Showing results for 
Search instead for 
Do you mean 
Reply
Enthusiast
Posts: 1
Registered: ‎12-16-2016
Message 1 of 8 (4,155 Views)

Sel/set button not working

Has anyone else had an issue with the sel/set dial on the FS5?  The dial works but the select does not.  You can push the dial in but it does not select the highlighted menu item.

I was going to send it in for warrenty but I was told it takes 4-6 weeks to repair... That's a problem for me.

 

Expert
Posts: 2,288
Registered: ‎11-23-2012
Message 2 of 8 (4,062 Views)

Re: Sel/set button not working

I don't understand why it would take 4-6 weeks to replace the rotary encoder/switch. It should be a 30min job at most. I guess they may not have the part in stock.

Rookie
Posts: 1
Registered: ‎01-11-2017
Message 3 of 8 (3,794 Views)

Re: Sel/set button not working

I had the same issue.  I found a solution, but it doesn't make sense to me.  

 

I could see that the "2" would go on and off on the manual volume adjustment display (shown above channel volume on bottom right of display).  When I switched channel 2 to "auto" instead of manual, the select button worked as normal.  

 

I have no idea what is going on here, but at least I can use my camera again!  If anyone can explain this, please do.

Rookie
Posts: 1
Registered: ‎03-11-2017
Message 4 of 8 (3,506 Views)

Re: Sel/set button not working

exactly the same thing happened to my unit (in the middle of a shoot, of course) - select button not working suddenly even though scroll does.

 

and exactly the same thing fixed it - changing audio channel 2 from manual to auto.

 

this is obviously a fault in the design or manufacture.

 

anyway - thanks for posting the 'solution'. Now only the audio is faulty (for the time being)

Expert
Posts: 135
Registered: ‎03-11-2014
Message 5 of 8 (3,468 Views)

Re: Sel/set button not working

Mine did same thing. I just use the selector switch on the handgrip. A buddy sent his FS5 in for the fix, took 6 weeks. Sony has a huge back up in service right now.....took almost 3 weeks to get my F5 back after having the firmware updated.

Highlighted
Expert
Posts: 120
Registered: ‎01-08-2016
Message 6 of 8 (3,439 Views)

Re: Sel/set button not working

One of ours was doing the same thing.  Had to send it out with a rental client with the instruction to use the hand grip to select things.  Thankfully they are one of our best clients and were cool with it.  Now the camera is back and working fine, go figure.

Rookie
Posts: 1
Registered: ‎08-27-2017
Message 7 of 8 (2,518 Views)

Re: Sel/set button not working

Exact thing happened to my camera and completly vexed me. I have tried your fix and it has magically worked thank you. Its Such a strange fault. Maybe its software rather than hardware??? Have you got any further intel?

Rookie
Posts: 1
Registered: ‎01-28-2018
Message 8 of 8 (668 Views)

Re: Sel/set button not working

Yep. Me too.

I havent tried the Audio Channel thing, but I have found that giving it a very gentle 'Fonzie" right next to the dial does the trick.

Seriously.

I hit the camera body, right behind the Sel/Set switch with a knuckle... not hard... about as hard as you would to break through a sheet of old tracing paper. And the ****** thing works.

 

Doesn't matter now. I'm selling this thing and moving to a different brand. Sony cameras look really good, and the built-in variable ND and the Raw output on the FS5 are sweet, but Sony menus are just too ****** arcane - totally counter-intuitive gibberish and submenu holes that burn time - and as is mentioned here, the customer service process is a disaster for working professionals.  I already got rid of our A7S2's, this is next.

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook