Skip to the end of navigation

Welcome to the Community!

Home Theater Products

Showing results for 
Search instead for 
Do you mean 
Reply
Rookie
Posts: 3
Registered: ‎10-07-2017
Message 1 of 4 (284 Views)

Sony SWF-BR100

Hi Sony, A few months ago I bought your SWF BR100 Sub woofer. It's an amazing sub and has been great to bring out the best in my Sony 4K TV.
Sadly a few weeks ago I started hear a popping noise from the sub, It's now all the time and is ruining watching movies, it's very random and have tried everything to fix it, even turning the volume down, power levels and changing frequencies.
A love my Sony products and do hope you know how to fix this popping noise. Maybe even if I can get a replacement ?
I look forward to hearing from you.
Moderator
Posts: 1,419
Registered: ‎11-04-2016
Message 2 of 4 (235 Views)

Re: Sony SWF-BR100

Hi Pockets24,

 

Welcome and thank you for considering the SONY Community!

 

We are sad to hear what happened with your subwoofer. Just like you, we also wanted our product to work flawlessly without having any issue. With regards to the popping sound you've experienced, we recommend following the additional steps below to fix it.

 

  1. Play a different source.
  2. Check the speaker wire for this channel to verify it is connected securely to both the speaker and the receiver.
  3. Check the speaker wire shielding to verify it has not been cut.
  4. If the speaker is not producing sound, verify that the speaker balance is set to the middle setting.
  5. Swap the two speaker connections at the receiver to see if the distortion stays with the same speaker.

 

For further assistance regarding your product, we highly recommend visiting our Sony Global Web site for information on contacting the Sony Support Center in your region at http://www.sony.net/SonyInfo/Support/.

 

Regards,

-Erin

 

If my post answers your question, please click the button below "Accept as Solution".

Highlighted
Rookie
Posts: 3
Registered: ‎10-07-2017
Message 3 of 4 (208 Views)

Re: Sony SWF-BR100

Hello ErinC,
I've tried the points in your post but a few I cannot as are you familia with the SWF-BR100. It's a wireless sub from Sony so it uses a dongle to send the signal.
All wires are good and I've shielded the sub from any other electrical devices. It's truly awful as this Sony Sub cost £249 which isn't cheap for a sub and this should never happen. I've sent an email to Customer Servies and all they sent me was a third party engineer repair centre which I drove to and it was a shoddy dirty shop. That I would take anything too. This is SONY isn't there anything better than this. Please can you help. Thank you.
Rookie
Posts: 3
Registered: ‎10-07-2017
Message 4 of 4 (143 Views)

Re: Sony SWF-BR100

Hello ErinC,
I've tried the points in your post but a few I cannot as are you familia with the SWF-BR100. It's a wireless sub from Sony so it uses a dongle to send the signal.
All wires are good and I've shielded the sub from any other electrical devices. It's truly awful as this Sony Sub cost £249 which isn't cheap for a sub and this should never happen. I've sent an email to Customer Servies and all they sent me was a third party engineer repair centre which I drove to and it was a shoddy dirty shop. That I would take anything too. This is SONY isn't there anything better than this. Please can you help. Thank you.

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook