Welcome to the Community!

Home Theater Products

Showing results for 
Search instead for 
Do you mean 
Reply
Rookie
Posts: 1
Registered: ‎09-03-2013
Message 1 of 2 (11,172 Views)
Accepted Solution

my stereo has power but wont turn on

my sony lbt-zx9 has power and is flashing words all over the screen but wont turn on for me. i dont have the remote either help please

Expert
Posts: 2,040
Registered: ‎05-23-2013
Message 2 of 2 (11,112 Views)

Re: my stereo has power but wont turn on

Please try the following steps. Please take note that because each of these steps represents a possible solution to this issue, check the power status after completing each step.

 

  1. Ensure the power cord of the stereo system is securely connected to a working AC electrical outlet.
  2. If the power cord is plugged into a surge protector, disconnect the surge protector and plug the power cord directly into the wall outlet.
  3. Plug the stereo system into a different AC electrical outlet to make sure there is not a problem with the current AC outlet.
  4. If the stereo system has a voltage switch on the rear of the unit, make sure the switch is set to the correct voltage for your area. Some stereo systems have a 110 to 220 Voltage switch on the rear of the unit where the default setting is 220V. Verify that this switch is set to 110V.
  5. Press and hold the POWER button. While pressing the POWER button, unplug the power cord from the AC electrical outlet. Release the POWER button, plug the power cord back into the AC electrical outlet and try powering the system back on. Also, try to reset the system to its default settings found on page 32 of the manual.

 

Click here for more steps.

 

If my post answers your question, please click on "Accept as Solution"

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook