Skip to the end of navigation

Welcome to the Community!

Other Products

Showing results for 
Search instead for 
Do you mean 
Reply
Enthusiast
Posts: 2
Registered: ‎12-25-2017
Message 1 of 5 (433 Views)

Sony LF-S50G - clocks not displayed

Facing issue with Sony LF-S50G that tried everything but clocks are not displayed. Segment LED display itself is working properly but no clocks. Tried several times reset and new pairing, changing location etc. It's very annoying as no solution found. Running latest firmware which has been updated directly out of box.
Version of firmwaru: 20034052
Version firmware Cast: 1.27.97091
Language: English (United States)
Country code: CZ
Device purchased in UK and used in Czechia.
Any help or help appreciated.
Enthusiast
Posts: 3
Registered: ‎02-11-2018
Message 2 of 5 (158 Views)

Re: Sony LF-S50G - clocks not displayed

I have the exact same issue. Any solution?
Enthusiast
Posts: 2
Registered: ‎12-25-2017
Message 3 of 5 (144 Views)

Re: Sony LF-S50G - clocks not displayed

Hi Jon,

 

Unfortunatelly no solution yet on my side as I tried to contact Sony support, but after many advices which didn't helped, like factory reset, new pairing, new pairing with other phone, use Google Home app :-) their final advice was to send device for repair.

This will not help in my opinion as I'm convinced that it is firmware bug related and waiting for new fw release:

https://www.sony.co.uk/electronics/support/smart-sports-devices-smart-speakers/lf-s50g

 

May I ask if you are also using Sony LF-S50G outside UK or other country where is not officially distributed like in my case Czechia?

 

Best regards,

Karel Novak

Enthusiast
Posts: 3
Registered: ‎02-11-2018
Message 4 of 5 (131 Views)

Re: Sony LF-S50G - clocks not displayed

Purchased retail in Australia and only used in Australia.

 

I left a case with Sony and waiting on a callback from an expert. Returned the first one to the shop to get a replacement and the replacement has the same issue (As it was same colour at same store I thought it might have been a faulty batch)

 

I agree with your thinking that it is a firmware bug as the display was working up to the point where the new firmware was downloaded (Last thing the display showed before it went dark was dl 99).

 

I'll post back if I solve it my end. I intend to try to swap again with another model from another store if Sony don't get back to me.

 

Thanks for responding!

Enthusiast
Posts: 3
Registered: ‎02-11-2018
Message 5 of 5 (74 Views)

Re: Sony LF-S50G - clocks not displayed

Found a solution from this guy

https://community.netgear.com/t5/Nighthawk-WiFi-Routers/Sony-LF-S50G-Wireless-Speaker/m-p/1507242

 

I reset it. Then using the google home app on my wife's tablet under her account set it up. I then went back to my original device (Pixel) and linked my account. Clock now displays.

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook