Skip to the end of navigation

Welcome to the Community!

Other Products

Showing results for 
Search instead for 
Do you mean 
Reply
Enthusiast
Posts: 5
Registered: ‎01-03-2017
Message 1 of 28 (6,388 Views)

Sony XAV-AX100 - Steering wheel controls don't work and clock is erratic

Last week I purchased a Sony XAV-AX100 car stereo and had it professionally installed in my 2016 Kia Soul + (the Plus model), which had the base stereo (without the Infinity system and without the Navigation system).  The installer used the Metra Axxess ASWC-1 to retain the steering wheel controls.  However, the only steering wheel controls retained are the "volume up", "volume down", "next track", and "previous track" buttons.  The "voice command" button, "answer call" button, and "end call" buttons are not retained.  I am annoyed that the "voice command" button wasn't retained, because I expected to be able to use that to invoke Siri when my iPhone is connected with CarPlay.

I talked to the installer about it, and he doesn't know of a way to make it work, even though retention of the steering wheel controls was one of the requirements I stated before I hired them to install anything.  I'm still trying to figure out why it doesn't work, and if there's a way to make it work, even if that means hiring a different installer, buying a different steering wheel control interface module, or buying a different car stereo that supports Apple CarPlay.

The stereo does have a "Steering Control Custom" menu that lets you manually map the steering wheel controls by choosing a function on the stereo, and then holding the button on the steering wheel that you want to assign to that function.  However, in the custom mode, you can't program all the steering wheel control buttons.  For example, if I program the "volume up" button, then when I try to program the "volume down" button, it doesn't do anything, so I can't program both "volume up" and "volume down".  Or if I program the "voice command" button, it cancels out (telling me "please retry") when I try to program the the "answer call" button or "hang up" button, clearing all previously-programmed buttons.  Likewise, there are many other button combinations that you can't program, such as programming both the "next track" and the "previous track" button.  So while I can program the "voice" command button to control Siri, I can only do that if I don't want basically any of the other steering wheel control buttons to work.  Is this a firmware issue on the Sony XAV-AX100?

I've also tried to custom program the Metra Axxess ASWC-1 steering wheel control interface module using the instructions in its manual, where you press each button in sequence during and watch the LED on the module.  That didn't make a difference, either.

I tried contacting Sony's support, but via their online chat option, the technician literally had two troubleshooting steps: reset the unit, and perform a factory reset on the unit.  That did not change the behavior.  When I tried to email their support, the online form that you have to submit only allows 450 characters to describe the problem, which is really only enough for a couple sentences, but not NEARLY enough to describe a technical problem.  When I called Sony support via telephone, the operator told me that they had such a high volume of calls that I couldn't speak to anyone and he couldn't even put me into a queue.  He asked for my phone number and will try to have someone call me back.

Also, the clock is erratic and unreliable.  Got in the car the other morning at 10:52am, and the clock on the radio said 5:50am.  On our 1/2 mile drive, we reset the clock to 10:53am.  Got to our destination, and it said 2:00am.  A moment later I looked at the clock, and it said 2:00am.  It's done this several other times as well, where it just displays absolutely random times on the clock.

This could be a great stereo, but the fact that the option to program custom steering wheel control buttons doesn't work, the fact that the clock is erratic, and the fact that Sony's support has been absolutely useless, mean that I cannot give a good rating.

Moderator
Posts: 4,146
Registered: ‎10-20-2014
Message 2 of 28 (6,353 Views)

Re: Sony XAV-AX100 - Steering wheel controls don't work and clock is erratic

Hi Jamesdvb,

 

I will send you a Private Message(PM).

 

 

Thanks,

>Joffrey

Enthusiast
Posts: 4
Registered: ‎01-07-2017
Message 3 of 28 (6,311 Views)

Re: Sony XAV-AX100 - Steering wheel controls don't work and clock is erratic

Hello,

 

Did you get your issue resolved.

 

I'm having a simular problem, I can't get the seek-, to work on my steering controls, either using custom or using the datalink maestro, also if you try to use the seek button to fast the radio reboots, the other thing that bothers me is, if you are using Apple Carplay, after you turn the car off, your phone goes nuts and restarts playing music, it's not an Apple Carplay issue, because my daughter Honda Civic doesn't do it with Apple Carplay. 

 

Other than that, I like the unit, it's nice, well, also, I don't know what the rear camera icon is for, you can only see the rear camera when the car it's in reverse.

 

Thanks

Enthusiast
Posts: 5
Registered: ‎01-03-2017
Message 4 of 28 (6,307 Views)

Re: Sony XAV-AX100 - Steering wheel controls don't work and clock is erratic

[ Edited ]
JoffreyS contacted me Wednesday (January 4th) to get my contact information so that they could escalate the issue and have a Product Specialist contact me back. I provided that info, but haven't heard back from anyone yet.

As to the Rear View Camera icon, my rear view camera comes on automatically when I put the car in reverse, but I can turn the camera on at any time by hitting the Rear View Camera icon. So you can turn it on when you're just parked, or even while driving. If yours doesn't switch to the camera when you press that icon, perhaps your camera behaves differently or is wired differently?
Enthusiast
Posts: 4
Registered: ‎01-07-2017
Message 5 of 28 (6,281 Views)

Re: Sony XAV-AX100 - Steering wheel controls don't work and clock is erratic

jamesdvd,

 

I'm assuming that your rear camera always has power?

 

Thanks

Enthusiast
Posts: 4
Registered: ‎01-09-2017
Message 6 of 28 (6,267 Views)

Re: Sony XAV-AX100 - Steering wheel controls don't work and clock is erratic

hi All, I am have the esame issue as here, after installing the device, the hang up, speek and dail buttom all not work. 

 

My car is mitsubishi outlander sport 2016 version, is anyone could share the solution to me so I can figure out, either like by a different model of connection string, or any other method, thanks !

Enthusiast
Posts: 5
Registered: ‎01-03-2017
Message 7 of 28 (6,261 Views)

Re: Sony XAV-AX100 - Steering wheel controls don't work and clock is erratic

I didn't do the wiring myself, but I guess the camera must always have power in order to work on demand. As far as I know, the installer only tapped into the video feed from the camera, not a power feed to the camera.
Enthusiast
Posts: 5
Registered: ‎01-03-2017
Message 8 of 28 (6,260 Views)

Re: Sony XAV-AX100 - Steering wheel controls don't work and clock is erratic

Out of curiousity, what steering wheel control adapter are you using between your Mitsubishi Outlander Sport and the Sony radio?
Enthusiast
Posts: 4
Registered: ‎01-09-2017
Message 9 of 28 (6,252 Views)

Re: Sony XAV-AX100 - Steering wheel controls don't work and clock is erratic

http://www.crutchfield.com/p_120ASWC1/Axxess-ASWC-1-Steering-Wheel-Control-Adapter.html?tp=3405

 

this one ,I bought all stuff from this website, and also the amplifier as :

 

http://www.crutchfield.com/p_120MITO03/Axxess-MITO-03.html?tp=3486

 

Both are suggested by http://www.crutchfield.com/, and also the backup camera in order to use the factory rear camera, the store helped me to ordered one 12v to 6v harness to connect, then it works as charm.

 

So now the only problem for me left the same as you do, three buttoms not working. 

Enthusiast
Posts: 1
Registered: ‎01-29-2017
Message 10 of 28 (6,042 Views)

Re: Sony XAV-AX100 - Steering wheel controls don't work and clock is erratic

I'm very much interested in retaining the steering wheel controls, myself. I have the same issue. Metra Axxess and Sony XAV-AX100. One thing I'll add that I noticed in the Axxess setup is that the device does not recognize the unit as a Sony, but rather "Metra OE". There were instructions on switching the head unit brand, but I wasn't able to get it to work as expected. I want to give it another shot at some point.

Anyway, hopefully there's a solution soon.

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook