Skip to the end of navigation

Welcome to the Community!

Television - Picture & Sound

Showing results for 
Search instead for 
Do you mean 
Reply
Newbie
Posts: 1
Registered: ‎11-12-2012
Message 1 of 21 (116,396 Views)
Accepted Solution

HDMI ports not working on kdl-40xbr4

Hello, I recently returned home from vacation to find that my tv, and many of my components were not functioning properly. Neighbors said that there was a very close lightning strike during the time I was away. My main problem now is that my kdl-40xbr4 has lost the use of its HDMI ports. The tv functions as normal if components are connected any other way, but the HDMI ports will not work at all. If I select one of the HDMI ports the banner at the top will indicate which input is active just like normal, but it will not go away as there is no picture or sound whatsoever coming through any of the HDMI ports. Has anyone ever encountered this issue, and does anyone know of a solution?
Expert
Posts: 1,046
Registered: ‎11-12-2012
Message 2 of 21 (116,395 Views)

Re: HDMI ports not working on kdl-40xbr4

Hello and welcome to the Users Discussion Forum.

1. Turn off the TV and unplug all the HDMI connections to the TV.
2. Turn on the TV and while holding down the up arrow on the remote control, press the power button on the TV.
3. The TV will turn itself off, then back on again then release the up arrow button.
4. Complete the initial TV setup wizard.
5. Turn off the TV and plug back all the HDMI connections to the TV.
6. Turn on the TV and verify those connected HDMI inputs are working or not.

If those HDMI ports are still not working then please contact Sony support directly for service options.
http://esupport.sony.com/US/p/support-c ... =KDL40XBR4
Enthusiast
Posts: 5
Registered: ‎12-23-2012
Message 3 of 21 (116,392 Views)

Re: HDMI ports not working on kdl-40xbr4

My Sony Bravia KDL-52VL150 HDMI inputs go black every 15 minutes or so, I have had it for over two years now and I was blaming the Sattelite reciever for a long time, I had a new one sent to me and also swapped with other recievers, finally ALL the inputs went out completely, I have had the tv in the shop twice now and had the MAIN MODULE replaced twice!  No Help! This is a SONY issue and they are trying to ignore it! It may be time for a CLASS ACTION LAWSUIT!

 

ANYONE ELSE HAVING THIS ISSUE SHOULD EMAIL ME AT deadhdmi-suit@yahoo.com , I WILL BE LOOKING FOR A LAWYER TO HANDLE THIS!

Rookie
Posts: 1
Registered: ‎10-26-2013
Message 4 of 21 (113,457 Views)

Re: HDMI ports not working on kdl-40xbr4

Did this solve anyone's issue with the hdmi connections?  We have a KDL-40WE5 - I tried as sony suggested but the tv will not turn off when I am pressing the up arrow button.  This has not solved our problem.  Sony, do you have any other ideas?  I have already upgraded the firmware, tried new cable and 2 different devices. 

Moderator
Posts: 1,726
Registered: ‎05-23-2013
Message 5 of 21 (113,415 Views)

Re: HDMI ports not working on kdl-40xbr4

Hi leeschw!

 
Thanks for the message. Go to the Set-up menu of the TV and select the option for Factory Settings. If the issue still persists after resetting the TV to factory settings, please contact the Sony Support Center in your region for further assistance. 
 
Enthusiast
Posts: 1
Registered: ‎01-30-2014
Message 6 of 21 (111,607 Views)

Re: HDMI ports not working on kdl-40xbr4

Worked for me perfectly!
Moderator
Posts: 1,726
Registered: ‎05-23-2013
Message 7 of 21 (111,595 Views)

Re: HDMI ports not working on kdl-40xbr4

That's good to hear. Smiley Happy 

Rookie
Posts: 1
Registered: ‎11-26-2014
Message 8 of 21 (105,710 Views)

Re: HDMI ports not working on kdl-40xbr4

Hi,

 

It's been almost 2 years since your post, just wanted to check if you were able to get the issue resolved or any luck with the lawsuit; I'm facing the same issue and the service charges are way too high and like you said, it didn't resolve the issue, then I'm stuck as even the part they are replacing carries only a 3 month warranty.

 

Rookie
Posts: 1
Registered: ‎02-13-2015
Message 9 of 21 (103,535 Views)

Re: HDMI ports not working on kdl-40xbr4

Hi spacekat

Im also facing the similar issue. After every 10-15 mins my screen goes black. For a long time i have been complaining my service provider as the message on the screen displays "unsupported signal. Kindly check the device output". Only 1/4 HDMI port is working and too with this issue. Have got my set top replaced and HDMI cable too but the problem still persists. Have contacted the sony customer support and they were of the view that the motherboard needs to be replaced and i was like WTF. Im sure this isnt the motherboard issue and must have some other fix..
So if you have got the fix to same issue then plz plz do share.
Thanks
Rookie
Posts: 1
Registered: ‎04-17-2015
Message 10 of 21 (102,169 Views)

Re: HDMI ports not working on kdl-40xbr4

I wish I didn't update my firmware. I know have this problem with my KDL-52V5100. I tried all the recommended fixes but still have the problem. Didn't happen before the firmware update.

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook