Skip to the end of navigation

Welcome to the Community!

VAIO - Windows 10

Showing results for 
Search instead for 
Do you mean 
Reply
Enthusiast
Posts: 3
Registered: ‎05-16-2017
Message 1 of 3 (996 Views)

How do you turn off touch screen before Login?

I just upgraded my sony vaio to windows 10, the only downside is that it activated my touch screen again, and I had it off for a reason. My touch screen randomly touches and clicks all over the screen without me even touching the computer, this means that I can barely move the mouse curser and makes typing impossible as it keeps clicking away from the text box, which means that typing in my login password is impossible.

How do I turn off the touch screen before the login? is there a way to turn it off from the BIOS? 

It would be great if there was a solution for this, otherwise I'm gonna have to throw out a £600 laptop and wash my hands of sony and microsoft altogether and get a macbook and an iphone.

Highlighted
Moderator
Posts: 4,642
Registered: ‎03-12-2015
Message 2 of 3 (951 Views)

Re: How do you turn off touch screen before Login?

[ Edited ]

 

Hi, Derek_m

 

Thank you for considering Sony Community! 

 

First, boot the computer into Safe Modehttps://us.en.kb.sony.com/app/answers/detail/a_id/43530/. You may try disabling the touch screen driver under Device Manager while in Safe Mode: 

 

Go to Device Manager >  Human Interface Devices. Find the touch screen driver, probably it is called "HID-compliant touch screen". Right click the driver and select Properties > Driver tab > Disable. You might need to restart the unit to take the effect. 

 

For further assistance, we kindly recommend visiting our Sony Global Website for information on contacting the Sony Support Center in your region at http://www.sony.net/SonyInfo/Support/.

 

Regards,

 

Vincent 

 

 

If my post answers your question, please mark it as "Accept as Solution"

 

Enthusiast
Posts: 3
Registered: ‎05-16-2017
Message 3 of 3 (936 Views)

Re: How do you turn off touch screen before Login?

Hey Vincent,

I was on the phone with microsoft and they were coming up with some weird solutions that wouldn't work, so I punched the screen really hard and that seemed to do the trick.
I have now disabled the touch funtion normally.

Regards,
Derek

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook