Skip to the end of navigation

Welcome to the Community!

VAIO - Windows 10

Showing results for 
Search instead for 
Do you mean 
Reply
amp Apprentice
Apprentice
Posts: 18
Registered: ‎08-20-2015
Message 11 of 87 (8,180 Views)

Re: Windows 10 installation on a VPCL116FX using a NVIDIA GEFORCE GT 240M DRIVER PROBLEM

@Darren_CP
Thank you very much! Do I need to change back the 330m to basic vga driver first so I can follow your instructions?
Expert
Posts: 76
Registered: ‎08-18-2015
Message 12 of 87 (8,170 Views)

Re: Windows 10 installation on a VPCL116FX using a NVIDIA GEFORCE GT 240M DRIVER PROBLEM

@amp

 

Sorry, you have me a bit confused here.  How did you end up with the GT330m showing up in your device manager ?  Is it working correctly or is it showing with an exclamation mark (missing driver) after using "Have Disk" / "Manually Select Driver". ?  I think I'd allow it to revert back to "Microsoft Display Driver" but really, it shouldn't make a difference either way. 

amp Apprentice
Apprentice
Posts: 18
Registered: ‎08-20-2015
Message 13 of 87 (8,155 Views)

Re: Windows 10 installation on a VPCL116FX using a NVIDIA GEFORCE GT 240M DRIVER PROBLEM

@Darren_CP

Sony provided an update (long ago) to the driver to remove the exclamation mark and show the 330m was installed. I actually tried to revert back to VGA driver to see if I could install the updated drivers that nvidia had on their website, that didn't work (like you said it wouldn't).  I will follow your instructions and once again, thank you.

Enthusiast
Posts: 4
Registered: ‎08-22-2015
Message 14 of 87 (8,122 Views)

Re: Windows 10 installation on a VPCL116FX using a NVIDIA GEFORCE GT 240M DRIVER PROBLEM

@amp, if you've upgraded to windows 10, the video driver should default to Microsoft Basic Display Adapter. Please note Darren_CP's solution would work only after upgrading to Windows 10 and downloading Windows 10 driver from nvidia's website.
amp Apprentice
Apprentice
Posts: 18
Registered: ‎08-20-2015
Message 15 of 87 (8,080 Views)

Re: Windows 10 installation on a VPCL116FX using a NVIDIA GEFORCE GT 240M DRIVER PROBLEM

@vigour
But it is the driver gt 330m that is not allowing windows 10 to install. I tried installing just the the Microsoft basic driver but it still comes back with the message that the GT 330 M is not compatible with Windows 10
Expert
Posts: 76
Registered: ‎08-18-2015
Message 16 of 87 (7,992 Views)

Re: Windows 10 installation on a VPCL116FX using a NVIDIA GEFORCE GT 240M DRIVER PROBLEM

[ Edited ]

@amp

 

Curious.  What part of the Windows 10 installation gives this error message ?  How are you installing the Windows 10 upgrade ?  Via a USb drive, or through the process started by Windows 10 upgrade icon located in the bottom right hand corner next to date / time ?

amp Apprentice
Apprentice
Posts: 18
Registered: ‎08-20-2015
Message 17 of 87 (7,972 Views)

Re: Windows 10 installation on a VPCL116FX using a NVIDIA GEFORCE GT 240M DRIVER PROBLEM

@Darren_CP

Got Windows 10 to install using USB and media toolkit.  I couldn't get the icon in lower right to work with the incompatible driver message always coming up.  I first had to uninstall the NVIDIA 330M driver that was installed through Sony Vaio update from a few years ago.  Reverted back to a generic microsoft driver.  Then used the USB external installation and got it to install.  I then followed everything that you laid out in the workaround to install the driver from the 341 folder.  IT WORKED insofar as I was able to start the NVIDIA installation process of the driver.  The problem is that it installed a 320 driver instead of the 330m driver and when I rebooted I got a perpetual black screen that I couldn't get out of. I got windows 10 to finally open through safe mode and unistalled the 320 driver and went back to generic.   I did pick a devsubsys close to what mine listed in the directions but nothing was exact so I am assuming I picked something wrong.

Expert
Posts: 76
Registered: ‎08-18-2015
Message 18 of 87 (7,952 Views)

Re: Windows 10 installation on a VPCL116FX using a NVIDIA GEFORCE GT 240M DRIVER PROBLEM

@amp

 

What Dev and Subsys do you have listed in device manager ?

amp Apprentice
Apprentice
Posts: 18
Registered: ‎08-20-2015
Message 19 of 87 (7,945 Views)

Re: Windows 10 installation on a VPCL116FX using a NVIDIA GEFORCE GT 240M DRIVER PROBLEM

PCI\VEN_10DE&DEV_0A2B&SUBSYS_905A104D&REV_A2
PCI\VEN_10DE&DEV_0A2B&SUBSYS_905A104D
PCI\VEN_10DE&DEV_0A2B&CC_030000
PCI\VEN_10DE&DEV_0A2B&CC_0300

Expert
Posts: 76
Registered: ‎08-18-2015
Message 20 of 87 (7,937 Views)

Re: Windows 10 installation on a VPCL116FX using a NVIDIA GEFORCE GT 240M DRIVER PROBLEM

[ Edited ]

Make the changes to the file "nvcti.inf".  This has a GT 330M listed.

 

As previously described, for sections [NVIDIA_SetA_Devices.NTamd64.6.1] , [NVIDIA_SetA_Devices.NTamd64.6.2] and [NVIDIA_SetA_Devices.NTamd64.6.3] , add an entry for

 

%NVIDIA_DEV.0A2B.905A.104D% = Section024, PCI\VEN_10DE&DEV_0A2B&SUBSYS_905A104D

 

Under [Strings} add

 

NVIDIA_DEV.0A2B.905A.104D = "NVIDIA GeForce GT 330M "

 

That should hopefully do the trick for you !  If it does, please mark post as solution and send some kudos  Smiley Very Happy

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook