Language: English / Spanish
Showing results for 
Search instead for 
Do you mean 

welcome to Sony's community site

Get involved! Whether you are here to ask or give help - we are happy you stopped by and look forward to seeing you in the future! Please watch our Welcome Video to get started.

Windows 8

Reply
Groovin'
Twinbird
Posts: 2
Registered: ‎07-20-2013
Accepted Solution

Unable to disable touchscreen

Hello,

 

The standard way to diable the touch screen in Windows 8 is to go to Control Panel > Hardware and Sound > Pen and Touch, and to uncheck a box that says something like "Use your finger as an input device". I have no such option available to me.

 

I tried the suggestion here: http://answers.microsoft.com/en-us/windows/forum/windows_8-tms/disable-the-touchscreen-for-a-windows... but I do not see an N-Trig driver, or any driver in Device Manager that is obviously related to the touchscreen.

 

Can anyone suggest a way to disable the touchscreen on my laptop?

 

Sony VAIO SVT15117CDS

Windows 8 x64

 

Thanks!

Please use plain text.
Sony Employee
ScottF
Posts: 154
Registered: ‎11-14-2012

Re: Unable to disable touchscreen

How to disable touch screen;

In Device Manager, expand Human Interface Device category to access ‘USB Input Device’ and disable it by right clicking, and choosing ‘Disable’ from the menu

 

There may be 2 or 3 of these USB Input Device items, the one corresponding to the touch screen is usually the final (bottom) device in the Human Interface Device category – it is not necessary to disable any other USB Input Devices

 

If my post answers your question, please mark it as "Accept as Solution".

Please use plain text.
Groovin'
Twinbird
Posts: 2
Registered: ‎07-20-2013

Re: Unable to disable touchscreen

Thanks ScottF, I disabled the USB Input Device item that was last in the list, and this disabled my touch-screen :smileyvery-happy:

Please use plain text.
Tuning Up
bkozlov
Posts: 1
Registered: ‎09-30-2013

Re: Unable to disable touchscreen

Thanks! It was helpful

True, the last two HID Input devices belong to logitech mouse in my case, but finally we did it!

Surprisingly, there is no much information on this important subject in the internet. And it is really annoying when during discussin people touch the screen and ...

Thanks!

Please use plain text.
Tuning Up
rajesh4096
Posts: 1
Registered: ‎10-27-2013

Re: Unable to disable touchscreen

Thanks a lot...

It worked. But not the last port, for me its second USB port from top.

Please use plain text.
Tuning Up
gryjffrs
Posts: 1
Registered: ‎12-25-2013

Re: Unable to disable touchscreen

Surprised to find no info regarding this on the laptop. On my Vaio there were two choices and it tuned out to be the first one. In any case I found my answer here and I appreciate it.
Please use plain text.
Tuning Up
beocom
Posts: 1
Registered: ‎04-08-2014

Re: Unable to disable touchscreen

OMG, Much thanks to you, ScottF!

 

This is the BEST post for resolving the touchscreen issue on my VAIO All in One.

 

I called Microsoft Tech support, waiting for about an hour on the phone, and they were trying to sell me their service for troubleshooting this very issue. After some frustration, I called their customer service and asked for a RMA # to return the product for a full refund.

 

MS Store should thank you for almost losing another customer. I am a fan of Apple and this is my second PC.

 

Please use plain text.
Tuning Up
cfallon
Posts: 1
Registered: ‎05-23-2014

Re: Unable to disable touchscreen

when I right click the usb port it only has option of unistal.... do I want to choose this? I only want to turn off the screen so I can clean it, if I unistall will I be able to load it back on?

Please use plain text.
Groovin'
dtgoetz
Posts: 1
Registered: ‎07-18-2014

Re: Unable to disable touchscreen

I was following these steps to disable my touchscreen.  With the mouse jumping around, I belive I clicked "uninstall" on the USB Input Device instead of disable.  That is my best guess.  I no longer have Pen and Touch available in the Control Panel.  The Panel Calibration program I downloaded to correct the jumping will not work.  I am assuming because the touch screen is turned off.

 

How can I reinstall or download the correct USB Input Device driver to get my touchscreen working again?

Please use plain text.
Top 40 Artist
Calvin_Francis
Posts: 41
Registered: ‎07-15-2014

Re: Unable to disable touchscreen

Hey Twinbird, Here's the link which can assist you.Hope it helps https://esupport.sony.com/CA/p/model-home.pl?mdl=SVT15117CDS&LOC=3#/howtoTab.Thanks - Calvin.

Please use plain text.