Skip to the end of navigation

Welcome to the Community!

VAIO - Hardware & Networking

Showing results for 
Search instead for 
Do you mean 
Posts: 3
Registered: ‎09-25-2014
Message 1 of 3 (5,111 Views)
Accepted Solution

Stamina/Speed button not working on Vaio S13A

I have a mid-2012 Win-7 Vaio S13A notebook (in detail: model SVS13A1C5E [1]), containing an “NVidia Geforce GT 640M LE” GPU as well as the CPU-integrated “Intel HD Graphics 4000”. Usually I could switch between these two by using the “Stamina/Speed” button, but it doesn’t work properly any longer. Unfortunately, I don’t know exactly when this problem started to arise, I just became aware of if a week ago.

Some useful information:

• On switching the “Stamina/Speed”-button, a small window appears for some seconds near the Notification area. It indicates the position of the hardware button correctly and switches between the two associated power plans (with the “Speed” mode creating much more fan noise). However, it uses the Intel graphics with both button positions, which means it doesn’t switch to NVidia graphics at all. (Actual graphics hardware in use can be determined by different software: everest, CPU-Z, CCleaner, …)

• System is not able to use the NVidia graphics even if the button is set to “Speed” on startup.

• When I deactivate “Intel HD Graphics 4000” driver in the Windows device manager, the machine is obviously not able to use the NVidia hardware, even if the driver is installed properly. It falls back to a very simple design with poor resolution.

• Meanwhile I had installed a couple of upgraded driver versions for the NVidia card downloaded from the NVidia website [2]. That worked for quite a while, so I’m not sure whether this might be a problem. Since I’m aware of this problem, I tried to use the original driver from the Sony website, but that doesn’t work as well at the moment.

• I also looked at the internet, and Google tells that I’m not the only one with this kind of problem. However, until now all the solutions provided there didn’t solve my problem:
1) (re-)installing drivers of NVidia card and Intel graphics (downloaded from [1])
2) (re-)installing Sony software: Sony Shared Library, Vaio Care, SFEP Driver (downloaded from [1])
3) I looked for some BIOS settings, that are not available on my machine (can’t remember exactly which ones that were…)

• The original “Windows 7 Professional 64bit” is still running. I have neither re-installed it, nor tried to upgrade to some Windows 8 or something else.

So, basically I have no idea how to fix this problem. Any idea/advice is appreciated, and if you have further questions, feel free to ask—Thanks!



Posts: 3
Registered: ‎09-25-2014
Message 2 of 3 (5,044 Views)

Re: Stamina/Speed button not working on Vaio S13A

Sadly, there is still no solution for this issue. The situation hasn’t changed at all.


No ideas on what’s on here?



Posts: 3
Registered: ‎09-25-2014
Message 3 of 3 (4,772 Views)

Re: Stamina/Speed button not working on Vaio S13A

[ Edited ]

Just in case anyone is interested:


I still have no solution on how to switch the entire system between Intel and NVidia graphics, like it was possible within the first two years after buying this Vaio S13A notebook. However, after updating the NVidia driver to the latest version (347.25), there is a solution that I can live with:

  • Switch to “Speed” mode (I’m just not sure whether this works in “Stamina” mode as well)
  • Open the NVidia control panel (via Windows control panel)
  • There are now several buttons to switch individual software to one of the available graphics adapters; play with it and have a look at the results
  • If you are interested, you can activate an “NVidia GPU activity” panel within Windows’ status bar that easily provides access to the NVidia control panel as well. Activate it via NVidia control panel, “Desktop” menu.

I don’t know whether this is a new feature that arrived with a driver update of the NVidia driver, or whether it was available all the time and I just haven’t taken notice of it. NVidia power is finally available again, and I can easily feel that when using software with advanced graphical demand (here: Ubuntu/Windows 10 in VirtualBox; HiRes Video playback; DxO image processing; …).



Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook