Skip to the end of navigation

Welcome to the Community!

VAIO - Upgrade, Backup, & Recovery

Showing results for 
Search instead for 
Do you mean 
Reply
Apprentice
Posts: 6
Registered: ‎04-02-2013
Message 1 of 9 (48,300 Views)
Accepted Solution

VAIO VPC CW - Fn hotkeys not working after Win7 reinstall

Hello all - 

 

Having a bit of trouble with my VPCCW190X. My hard drive failed and I had to replace it. In doing so, I installed Windows 7 Home Premium fresh, with none of the Sony/VAIO additional software, hoping to keep clutter down. Naturally, this means that now my Fn hotkeys (like F3/F4 for volume, etc.) are no longer working. I tried installing the drivers & utilities I found on this page, but no luck at this point. 

 

I think it may be because on the drivers and utilities download page for my unit, there's only one thing under "Notebook Control and Utilities": the Setting Utility Series Update. I know other models have a complete Notebook Utilities package. I've gone through this process at least once before, and been able to find the correct software somewhere around the site, but this time Support is telling me I need to purchase a Recovery disk. And, frankly, to ****** with that. 

 

Can someone please point me to the correct drivers/utilities to make this simple thing work properly? 

 

Much appreciated,

LP

Moderator
Posts: 0
Registered: ‎11-12-2012
Message 2 of 9 (48,279 Views)

Re: VAIO VPC CW - Fn hotkeys not working after Win7 reinstall

LiteralPhilosop,

 

Please download and installing the following software from top to bottom. 

 

1. Sony Share Libraty under SYSTEM COMPONENTS

2. Video Driver

3. SONY Notebook Utilities for XP and run in in compatibility mode

4. VAIO Event Service Update under SYSTEM SOFTWARE for Windows 7

 

 

Apprentice
Posts: 6
Registered: ‎04-02-2013
Message 3 of 9 (48,269 Views)

Re: VAIO VPC CW - Fn hotkeys not working after Win7 reinstall

Well, that got me close, so I appreciate the help so far. Definitely got the sound working, although it doesn't give me the on-screen confirmation bar the way it used to. Brightness is interesting - you get a beep, and the little bar shows up on the screen. However, the bar looks weird, and you can only ever get it to show one block at the bottom, or none at all. And the brightness doesn't actually change. 

 

Plus, I definitely didn't have to go through any Compatibility Mode shenanigans the last time I did this. So there's still a better answer out there somewhere. But thanks for getting the sound - that's the more important bit!

Moderator
Posts: 1,574
Registered: ‎04-01-2013
Message 4 of 9 (48,251 Views)

Re: VAIO VPC CW - Fn hotkeys not working after Win7 reinstall

Hi LiteralPhilosop,

 

Since some are working, please follow this Clean installation of windows 7   to get the basic operations you wanted other than the Sony software.  The list under DOWNLOAD DRIVERS #3 will do what you wanted. 

 

Nick--

Apprentice
Posts: 6
Registered: ‎04-02-2013
Message 5 of 9 (48,206 Views)

Re: VAIO VPC CW - Fn hotkeys not working after Win7 reinstall

Hi, Nick T -

 

Thanks very much for your reply. I've been away because I was planning to do that whole list, and then get back to you with (I hoped!) a successful report. 

 

Unfortunately, I got almost all the way through the "Getting Started" step, when I ran into a snag. It tells me to download and have available the "Notebook Control Device" and "Sony Notebook Utilities" drivers/applications. Unfortunately, on my device's download page, as I mentioned in my first post, neither of those things exists. The only thing under the Control and Utilities section is the Setting Utility Series Update, which (from what I've seen yet) doesn't appear to affect these functions. So I'm still at square one. 

 

Any further thoughts?

Respectfully,

LP

 

Moderator
Posts: 1,279
Registered: ‎11-12-2012
Message 6 of 9 (48,203 Views)

Re: VAIO VPC CW - Fn hotkeys not working after Win7 reinstall

[ Edited ]

LiteralPhilosop,

 

Sorry for the confusion... for some reason they named it "Setting utility series" on this model.  That is the correct analog to "notebook utilities".  Please use that package.

 

Dont forget the Vaio Event Service utility as well.  That is the software that senses when you press one of the function keys.

Apprentice
Posts: 6
Registered: ‎04-02-2013
Message 7 of 9 (48,188 Views)

Re: VAIO VPC CW - Fn hotkeys not working after Win7 reinstall

OK, thanks for that, Ryan. I'm curious: why doesn't the clean-install page that Nick linked earlier mention the Event Service? And should I install it after the Setting Utility Series?
Moderator
Posts: 1,279
Registered: ‎11-12-2012
Message 8 of 9 (48,174 Views)

Re: VAIO VPC CW - Fn hotkeys not working after Win7 reinstall

[ Edited ]

My best explanation of this is because we bundled all of this software into one thing called "Notebook Utilities" in newer models.  Older models such as the CW still have those old names.


There do not appear to be any listed dependencies between Setting Utility and Event Service, so the order in which they are installed should not matter.



Rookie
Posts: 1
Registered: ‎01-30-2016
Message 9 of 9 (24,244 Views)

Re: VAIO VPC CW - Fn hotkeys not working after Win7 reinstall

Hello there,

 

I also have a Vaio VPC and had the same issue.

I solved it using this page http://www.sony.co.uk/support/en/content/cnt-dwnl/prd-comp/soaves-00225892-0041_8624

And a little trick (complete url) to retrieve VAIO Utilities listed (and not easy to find on the site)

  1. a) Battery Checker (SOABCU-00225876-0041.EXE) http://download.sony-europe.com/PUB/VAIO/Original/SOABCU-00225876-0041.EXE
  2. b) Setting Utility Series (SOASUS-00240869-0041.EXE) http://download.sony-europe.com/PUB/VAIO/Original/SOASUS-00240869-0041.EXE
  3. c) VAIO Control Center (SOAVCC-00225884-0041.EXE) http://download.sony-europe.com/PUB/VAIO/Original/SOAVCC-00225884-0041.EXE
  4. d) VAIO Event Service (SOAVES-00225892-0041.EXE) http://download.sony-europe.com/PUB/VAIO/Original/SOAVCC-00225884-0041.EXE

then, after a restart, I could install the one from the page. (first link) But in fact it uninstalled a previous version.

I had to restart again and install it "again". Then final restart and tadaaa :-)

Hope this helps

 

Get Social

Share your ideas Watch YouTube Support Videos follow us on Twitter Visit us on Facebook